Using Pathway Connect Octo Nodes

This is the forum, where you can add your wishes and feature requests.

Moderator: MADRIX Team

Locked
DProvorse
Posts: 6
Joined: Mon Mar 12, 2012 12:19 am

Using Pathway Connect Octo Nodes

Post by DProvorse »

Not sure if this the correct place to put this or not so feel free to move if necessary.

I have several large installs ongoing that are between 30k and 90k channels. We use almost exclusively Pathport Connect Nodes in the field. Most of these are Octo's which are 8 port output nodes.

http://www.pathwayconnect.com/content/view/166/29/

Currently in Madrix the most ports I can configure in a single device is 4 so I have to create 2 devices for every Octo to get the correct data to them.

Another unusual thing I have found, but I work around, is that the universes are always off by 1. So if my patch has the fixtures stuck in universe 50 and I send them out as 50 they show up in Pathport as 51 lol.

Thanks in advance guys!

Dustin Provorse

R2W Inc
User avatar
Wissmann
Developer
Developer
Posts: 764
Joined: Fri Feb 23, 2007 3:36 pm
Location: Germany
Contact:

Re: Using Pathway Connect Octo Nodes

Post by Wissmann »

Ok, you have two questions.
1. Is it necessary to create 2 devices in MADRIX for one Pathport Octo
2. Universes off by one

At first i have to say we have unfortuntaely no Pathport Octo here in the office for test.

Regarding your first question.
The original Art-Net protocol only support 4 ports at one node.
Therefor it is necessary to add two devices inside MADRIX for the same IP with different port configurations.
There are two ways to get this.
Either you create the devices by hand or you use the [Find Auto] Button. But this only works if the Pathport node supports the ArtPollReply command.
If the Pathport support it you get at least one node with 4 ports automatically.
If the node support the flags "BindIp & BindIndex" further MADRIX is able to create two nodes with different port settings automatically.

Now to your second question.
Inside MADRIX you can assign virtual (MADRIX) universes to the device ports.
So for example the virtual MADRIX universe 1 is mapped to the first port of the device. In this case you have to enter a 0x00 inside the Art-Net Configure Device dialog of MADRIX. This means Universe 1 get the number 0 at the Art-Net Device settings of MADRIX.
I gues you set up a 0x01 instead of 0x00 for this example.
LEDs are nothing without control ;-)
Locked
Back to top